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Software License Agreement

NOTE

DATAQ Instruments’ hardware and software products are NOT designed to be used in the diagnosis and
treatment of humans, nor are they to be used as critical components in any life-support systems whose failure
to perform can reasonably be expected to cause significant injury to humans.

LICENSE AGREEMENT

(SINGLE-USER PRODUCTS)
THIS IS A LICENSE AGREEMENT AND NOT AN AGREEMENT FOR SALE. A LICENSE AGREEMENT IS A
LEGAL AGREEMENT BETWEEN YOU, THE END USER, AND DATAQ INSTRUMENTS, INC. PLEASE
READ THIS LICENSE AGREEMENT CAREFULLY BEFORE OPENING THIS SEALED PACKAGE, OR
ACCEPTING ITS TERMS ELECTRONICALLY. IF YOU DO NOT AGREE WITH THE TERMS AND CONDI-
TIONS OF THIS LICENSE AGREEMENT, PROMPTLY RETURN THE PACKAGE UNOPENED AND YOUR
MONEY WILL BE REFUNDED, OR IF DELIVERED ELECTRONICALLY PRESS THE "DO NOT ACCEPT
AND STOP" BUTTON.

1. This software package is protected by federal copyright law and international treaty.

2. By law, you, the end user, may do the following: a) make a copy of the software solely for backup or archival pur-
poses, or other copies only in accordance with item (4) below.

3. Federal copyright law prohibits you from making any other copy of the software for any other reason without our
permission. Federal copyright law also prohibits you from copying the written materials accompanying the software
without first obtaining our permission.

4. You may install our WinDaq data acquisition software on multiple computers, provided that one software license
has been purchased (or granted) for each DATAQ Instruments hardware unit that is to be used with the software. For
example, the purchase of one hardware unit and one software unit allows you to install the software on as many com-
puters as desired. But if a second unit is purchased, that unit cannot be used with the original license installed on any
computer unless a second license is also purchased. To do otherwise is a violation of this License Agreement. This
restriction does not include licenses for WinDaq Waveform Browser (playback) software, which are free.

5. If the software is a library product, then you have a royalty-free right to reproduce executable files created using
the software.

6. You may not alter, modify or adapt the software or accompanying materials. In addition, you may not translate,
decompile, disassemble or reverse engineer the software. You also may not create any derivative works based on this
software. A derivative work is defined as a translation or other form in which the software may be recast, transformed
or adapted.

LIMITED WARRANTY

DATAQ Instruments, Inc. warrants that this program will perform in substantial compliance with the published spec-
ifications and documentation supplied in this package, provided it is used on the computer hardware and with the
operating system for which it was designed. This warranty is limited to a period of 90 days from the date of the orig-
inal purchase.

If you report a significant defect in performance, in writing within 90 days of purchase, DATAQ Instruments will
attempt to correct it or, at its option, authorize a refund of your license fee.

DATAQ Instruments warrants that the original disks and documentation are free from defects in material and work-
manship, assuming normal use, for a period of 90 days from the date of purchase. If a defect occurs during this
period, you may return the faulty disk or documentation, along with a dated proof of purchase, and DATAQ Instru-
ments will replace it free of charge.



Except as specifically provided above, DATAQ Instruments makes no other warranty or representation, either express
or implied, with respect to this software, the disks or documentation, including their quality, merchantability, or fit-
ness for a particular purpose. In no event will DATAQ Instruments be liable for direct, indirect, special, incidental, or
consequential damages arising out of the use or inability to use the software or documentation, even if DATAQ
Instruments has been advised of the possibility of such damages. The warranties and remedies set forth above are
exclusive and in lieu of all others, oral or written, express or implied.

DATAQ Instruments is not responsible for any costs including, but not limited to, those incurred as a result of lost
profits or revenue, loss of time or use of the software, loss of data, the costs of recovering such software or data, the
cost of substitute software, claims by third parties, of other similar costs. In no case will DATAQ Instruments' liability
exceed the amount of the license fee. The warranties provided give you specific legal rights. You may have other
rights which vary from state to state. Some states do not allow the exclusion of incidental or consequential damages,
or the limitation of how long an implied warranty lasts, so some of the above may not apply to you.

DATAQ Instruments retains title to and ownership of the software. DATAQ Instruments retains all rights not
expressly granted. Nothing in this License Agreement constitutes a waiver of DATAQ Instruments' rights under the
U.S. copyright laws or any other Federal or State law. DATAQ Instruments or its designee has the right to audit your
computer and software usage to determine whether any unauthorized copies of this program have been made. Any
authorized copy of the software covered by this Agreement, including authorized backup copies if any, must include
DATAQ Instruments' copyright and trademark notices.

U.S. GOVERNMENT RESTRICTED RIGHTS

The software covered by this Agreement and documentation thereto are provided with RESTRICTED RIGHTS. Useg,
duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(I)(ii) of the
Rights in Technical Data and Computer Software clause at 52.227-7013. The manufacturer of this software and doc-
umentation thereto is DATAQ Instruments, Inc.; 241 Springside Drive; Akron, Ohio 44333; (330) 668-1444.

This Agreement is governed by the State of Ohio in the United States of America.

If you have any questions about this License Agreement, write to: DATAQ Instruments, Inc.; 241 Springside Drive;
Akron, Ohio 44333.
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1. Introduction

This manual contains information designed to familiarize you with and provide a “Fast Start” for WINDAQ waveform
recording software, WINDAQ Waveform Browser playback and analysis software, ActiveX Controls, and XControls
Software Option. For a complete and detailed description of each function contained in WINDAQ software please use
the Help Files.

WINDAQ Software

Use WINDAQ software with any DATAQ Instruments hardware product. The WINDAQ software package contains
both recording and playback software. The recording software allows you to record waveforms directly and continu-
ously to disk while monitoring a real time display of the waveforms on your computer screen.

WINDAQ/L.ite Recording Software limits maximum throughput to 240 Hz when in RECORD mode. WINDAQ/Pro
Recording Software features a sample rate limited only by the maximum sample rate of the hardware. In addition to
WINDAQ/Pro's features, WINDAQ/Pro+ Recording Software allows you to tailor sample different channels at differ-
ent rates by entering a sample rate divisor value (1 to 255) for each channel.

WINDAQ Waveform Browser playback software allows you to review, measure, analyze, compress, cut-and-paste,
export/import, and otherwise manipulate the recorded waveform information.

Help Files

Click an item in the Help menu or use the context-sensitive help feature encoded into the software to access the Help
Files. The Help menu provides links to specific Help Topics. For example, clicking on Mouse in the Help menu will
take you to the portion of the help file regarding Mouse operations. Highlight a menu item and press F1 to utilize the
context-sensitive help feature. The Help File will open to the page most relevant to that menu item, its functionality,
and activating procedure.

22 DI-158 Acquisition 41272243
ZEN Edit  Wiew Scaling  Options  Help

Cpen... CerlH+O
Cpen Reference File... CtrHR

Save Defaulk Setup
Record F4
Pressing F1 at Browse in the

File Menu opens the Help
File at the Browse page.

Browse

E? WinDanq Acquisition Software

Hide Frint
[7) Command Reference

@ Acquie Data to Disk

@ Acquizition Triggening L Previous | Hext
@ Beep on File Full o
() Browse
Browse
Activating Procedure
@ Channel Seftings

EBX

[¢] ©

“Weh Site Upgrade Center

LContents ] Index ] §earch|

G Functons _ DATAQ: WINDAQ® Acquisition Software

INSTRUMENTS

@ Ciose Function
@ Configure Channels
& Copy Opens the last file recorded.

@ Default Conditions

[P [ DY
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Help Files contain 3 basic window panes. The Options pane gives printing options, browser functionality, and some
helpful links to our web site. The Contents pane has three tabs - the Contents, Index, and Search Tabs. These tabs
provide an easy way to find exactly the help information you need. The Main pane shows the main text and also pro-
vides browsing functionality to the help file. Click on the Next and Previous links to browse through the Help File
comparable to paging through a book.

Options

Contents, Image, and Search Tabs Main Window

E? WinDanq Acquisitiun Software

|
Hide
Contents l Index ] §earch] . D T 0 ~
A (i . wgw 7
2] Acauistion '] r_ A » WINDAQ® Acquisition Software
(7] welcome INSTRUMENTS
Dacumentation Conventions and General [
Fast Start
Furctions
Reference Materials
fricsee
File Size in KiloBytes = IZEU'JIJ
At a sample rate of 1000 Sfs and pack factor of 1.000,
R ding Time in [h insec = [3:33119
Cancel
' '
Chanrel= [T
\ Level= 0ol
Hysbenps = I 0ok -
¢ Pounts Belose Trgger =
|1D|:1 4sec
Poants After Teigges =
IB‘-U! 3.2 mmc
W Haik Tigge: Ponk
| [Getlevel]] cancel |
< >
-

Introduction
2



WINDAQ Software User’s Manual

Multimedia Demonstration Videos

The icon shown below indicates the availability of a Multimedia Demonstration Video on the internet or in the help
files for that particular subject. Click on the icon to view the Demo (internet connection required) or open the Help
Files to view any of the WINDAQ Software Demonstration Videos..

Video Icon
Click to view Demo

Conventions Used in the Documentation

Before using WINDAQ software, please read this section to understand some of the terms and notational conventions
used here and in the Help Files.

General Conventions

Commands you choose are given with the menu name preceding the command name. For example, the phrase
“Choose File Open” tells you to choose the Open command from the File menu. This haming convention describes
the sequence you follow in choosing a command - first you select the menu, then you choose the command.

Mouse Conventions

In general, most mouse actions require only the left mouse button. For example, carrying out a menu command or
working in a dialog box requires only the left mouse button. Since the majority of mouse procedures are done with
the left mouse button, we will not specify which mouse button to click, drag, or double-click in the procedure unless
the action uses the RIGHT mouse button. For example, “Double-click the right mouse button anywhere in the bottom
annotation line to move the cursor to the lowest displayed waveform valley.”

e “Point” means to position the mouse pointer until the tip of the pointer rests on what you want to point to on
the screen. For example, “Point to the View menu.”

e “Click” means to press and immediately release the mouse button without moving the mouse. For example,
“To display the menu that contains the command you want, click the menu name in the menu bar.”

e “Double-click” means to click the mouse button twice in rapid succession. For example, “Double-click the
icon to start the program.”

»  “Drag” means to press the mouse button and hold it down while you move the mouse; then release the but-
ton. For example, “Drag down to Data Cursor to enabled the cursor for on-screen display.”

WINDAQ Operating Modes

WINDAQ waveform recording software has three operating modes: Setup, Record, and Standby. Each operating mode
shares many features with the other two, but specific modes may restrict features or disable some functions alto-
gether.

WINDAQ Recording Software starts in the SET UP operating mode. In SET UP mode you can configure data acquisi-
tion parameters—such as the number of acquired channels, channel gain, and channel offset—and customize the real
time display. SET UP operating mode provides access to most data acquisition functions and adjustments including

control of the real time display screen's scaling and offset functions. The SET UP mode displays data in real time but
does not store data to disk. This mode limits sample rate only by the capabilities of the hardware. In other words, you

Introduction
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can sample as fast as your instrument will allow. When in this mode, the Status: area of the bottom annotation line
displays SET-UP.

The RECORD operating mode stores, or streams, data to disk. Activate the RECORD mode by selecting Record from
the File menu. You can use all waveform recording features and functions (with some restrictions) while in the
RECORD mode except the following: Channel-specific operations (i.e., channel number, gain, offset) and sample
rate adjustments. Waveform information continuously streams to disk while the real time display remains active.
RECORD mode limits sample rate to 240 Hz maximum throughput when using WINDAQ/L.ite but does not limit the
sample rate when using WINDAQ/Pro or Pro+ (limit determined by hardware). When in RECORD mode, the Status:
area of the bottom annotation line displays RECORD.

Use the STANDBY operating mode to temporarily suspend (pause) waveform recording to disk. Select Stop in the
File menu to enter STANDBY mode. You can use all waveform recording features and functions except channel-spe-
cific operations (i.e., channel number, offset, etc.) and sample rate adjustments. The STANDBY mode displays data
in real time while waveform recording to disk has been stopped. When in this mode, the Status: area of the bottom
annotation line displays STBY. Start and stop as many times as desired during a data acquisition session.

Introduction
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2. Getting Started

The following items are included with each instrument purchase. Verify that you have the following:
*  Your DATAQ Instruments, Inc. hardware device.
»  Appropriate communications cables (this will vary according to the instrument you purchased).
»  The DATAQ Instruments Resource CD-ROM (if provided - some devices do not come with a CD).
e This user's manual, which documents WINDAQ Software.

Call DATAQ Instruments at 330-668-1444 to report missing or damaged items—we will guide you through the
appropriate steps for replacing them. Save the original packing material in the unlikely event that your unit must, for
any reason, be sent back to DATAQ Instruments, Inc.

Refer to your hardware documentation for hardware and software installation instructions. Once installed, connect
input signals as described in your hardware manual.

Once everything is installed and connected start WinDaq Acquisition software. A real-time display of signals dis-
plays on your screen.

Getting Started
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3. WINDAQ Data Acquisition

WINDAQ Data Acquisition Software acquires, displays, and records waveform data. Before running the software, you
must correctly install all hardware and software components and connect your signals. Follow the basic steps pre-
sented in this chapter for a fast start to your first data acquisition session. These fast start steps outline the condensed
procedure for recording waveforms to disk. You will perform most of these functions every time you record with
WINDAQ Acquisition.

Help Files

For a complete description of all software functions, see the context-sensitive Help Files. To access the context sensi-
tive help either highlight a menu item and press F1 (this will take you directly to help regarding that menu item) or go
to the Help menu and click on Contents. The Help Files elaborate and detail the functions in this Chapter and contain
detailed descriptions of each additional function available in WINDAQ Acquisition Software. After you have become
familiar with the functions described here, take some time to look over the rest of the functions detailed in the Help
Files.

Fast Start

Step 1 Enabling Channels for Acquisition

DI-145 USB Data Acquisition Starter Kit

1. Inthe Edit menu click on Channels....

The Ch: block cursor will blink in the Channels field on the status bar. The currently active list of ~ fick icon for Demo

enabled channels are displayed in this field, immediately to the left of the cursor (blinking prompt).

2% DI-145 Acquisition
File Edit Wew Scaling Options  Help

Mode: Oscill annel=z: 1.2.3. I |
So= (F3): 240 Compres=fFr . Stu;ag@: ¥ u=ed
| | 4 M aBninl N N H N N N N N N N - H N N N
currently active blinking prompt
channels

2. Enter the desired channel number and press the ENTER key. Repeat for each desired channel. Each activated
channel will have its corresponding channel number displayed in the currently active channels list.

3. When all desired channels have been enabled, exit the channel configuration routine by pressing any key other
than the “D” or “I” key.

Type the channel number preceded by a minus (“-”) sign to disable channels. For example, typing “-3” disables chan-
nel 3 and removes it from the list of currently active channels.

Note: You may not enable channels in RECORD mode.

WINDAQ Acquisition
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All Other DATAQ Instruments Product

You may enable or configure channels for acquisition only in SET-UP mode—you cannot add,
delete, or configure channels in RECORD mode. To activate ADC channel configuration click on
Channels... in the Edit Menu or double-click on the Channels: field in the status bar. This displays

. ) Click icon for Demo
the Channel Selection grid.

x
Channel=: 1111111111 2222222222333
123458 7890123458 789012345 789012
pr-720:/j/}/ | =
HUHE A
B:
C:
D:
E:
F:
G:
Click to =elect {(check) or deselect.
Double click to =zelect differential (+).
Click right to select digital input (I).
MU letters occupy the expan=ion input=.
0K | Cancel |

The channel selection grid displays the current status of all channels and allows you to enable and disable channels.
In the illustration above, the boxes formed by the top row of the grid represent the internal channels available on the
hardware device (the numbers above the top row of boxes refer to the channel numbers). The above example shows a
DI-720 with channels 1-4 configured for single-ended inputs and channel 7 configured for differential input. The sub-
sequent rows underneath the top row of the grid (labeled A, B, C, etc.) represent each group of 32 external analog
input channels activated through use of an analog channel expander (like a DI-725).

The next graphic displays a single DI-725 32-channel analog expander added to the original DI-720. Enable and dis-
able channels for an analog channel expander in Row A. At the end of the row labeled DI-720, you’ll notice a pair of
“A”s in the 31 and 32 positions. This indicates active status for the DI-725 and successful communication with the

DI1-720. WINDAQ Acquisition reserves channels 31 and 32 of the DI-720 to multiplex with the DI-725 (these channels
cannot receive direct input when multiplexed). Channel 31 multiplexes the first 16 channels on the attached channel
expander and channel 32 multiplexes the next 16 channels. Adding a second expander displays a “B” at channels 29
and 30 indicating use by the second expander. Each expander added continually increments channels in this manner.

WINDAQ Acquisition
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|
Channels=: 11111111112 22222%22%223373
1 2345678901 323458867 8901234567 889012
p1-720:/j/h/ 1 - A4
wx &y )/
BE:
C:
D:
E:
F:
G:
Click to select (check) or deselect.
Double click to =elect differential (+).
Click right to =elect digital input (I).
HUX letters occupy the expansion inputs.
0K Cancel |

Use the instructions below to enable a channel for single-ended, differential, or digital input.

Enabling/disabling a channel
A check mark in the channel box indicates an enabled channel. Click on a channel box to enable/disable a channel
and place/remove a check mark in/from its channel box.

Enabling/disabling a differential channel

Note: If your instrument has fixed differential channels (like models DI-722-16, DI-722-32, DI-730) enable the chan-
nels as noted above—place a check mark in the desired channel box. If your instrument does not have fixed differen-
tial channels, follow these procedures to designate channels as differential. See your hardware manual to determine if
your instrument has fixed differential channels or not.

Point to the box in the grid representing the desired channel and double-click the left mouse button. This will display
a plus sign (+) in the desired channel box. Double-clicking a second time removes the plus sign and disables the chan-
nel.

Note: You cannot enable a differential channel numbered higher than one half the total number of channels provided
by the device (assuming the device supports differential inputs).

A differential channel requires two input terminals (positive and negative). For example, in order to designate chan-
nel 1 as differential requires both the channel 1 input terminal (positive input) and the channel 9 input terminal (neg-
ative input). Enabling a differential channel automatically enables its corresponding input (the negative terminal) and
places a minus sign (-) in the Channel Selection grid, designating it as the low input of the differential pair.

Enabling a digital input channel
An “I” in the channel box indicates a digital channel. Right-click on a channel box to enable/disable a channel and
place/remove an “I” in/from its channel box.

WINDAQ Acquisition
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F
Channels: 1111111111222 2222222333
12345678901 2345878901 23456789012
pr-720 4 AT |4 - ala
WU A:\/\/\/
BE:
C:
D
E:
F:
5
Cliclk to =elect (checlk) or deselect.
Double click to =select differential (+).
Click right to =select digital input (I).
MOX letters occupy the expansion inputs=.
oK Cancel |

WINDAQ Acquisition acquires the eight digital input bits (accessible as defined by the hardware) on a digital input
channel and scales the acquired data between +128 and -128, with 0 in the center.

Selecting Digital Plot in the Scaling menu will also display digital data. This feature horizontally splits the waveform
strip configured for digital input into eight equal parts. WINDAQ assigns the top-most waveform as digital input 0, the
bottom-most digital input 7, with the remaining 6 digital inputs allocated in logical order within the strip. This feature
provides quick-look capability to determine the state of a digital input line.

Channel Selection Notes

Single-ended, differential, and digital channels may coexist in any combination that the hardware allows.
WINDAQ Acquisition always sequentially samples from the lowest channel number specified to the highest.
You may enable any number and any combination of channels that the hardware will allow.

The RECORD mode does not allow configuration of the number or type of channels enabled.

Step 2 Viewing Enabled Channels

The default number of channels displayed varies by instrument. Click on Format Screen in the

View menu to change the current display. In the format box, click the desired display format. For-

mat Screen allows for overlapped and non-overlapped waveform displays. Click icon for Demo

WINDAQ Acquisition
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non-overlapped display

2% DI-700 - WinDag/Lite O
File Edit

Wigw  Scaling

Hode: O=scill
So= (Fii:

Options  Help

Channels: 2

625

013

244 .1406 Compres=s(F7). 1

Storage: x

Volt

—. 625

10.000

—10.000

S = -CHAN

127 0703 =ec/DIV. 0.164

Status . SET_UF

2% DI-700 - WinDag/Lite 0

overlapped display

File Edit Wiew Scaling Options  Help
Hode: Oscill Channels: 2
S-= (F3): 244 1406 Compress(F7): 1 Storage:
1.250 N : P N 10.000
Channel 1 Waveform-" | : | ™
LB70 L6200
Volt Volt
-1.250 N R N R N R : =10.000
So=-CHAN: 122 0703 =ecsDIV: 0.164 Statu=: SET-UFP
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An overlapped format allows you to closely examine the relationship between two waveforms. A non-overlapped for-
mat allows you to isolate each waveform’s transition to within a defined area. Whatever the timing relationship of
your input signals, use any display format at any time without affecting the waveform information stored to disk. Dis-
play format changes only affect the way you view waveforms on your computer’s monitor.

Note: To display eleven channels (or some other number not listed in Format Screen) select the User-specified
option and enter 11 in the Number of Channels dialog box.

Step 3 Specifying a Sample Rate
The total sample throughput rate is the rate that your instrument acquires samples for all channels combined. For

example, to acquire two channels of data at 100Hz each would require a sample throughput rate (total scanning rate)
of 200Hz (2 channels x 100Hz = 200Hz). The Sample Rate must be specified before recording; default varies.

22 DI-154 Acquisition

File Edit Wjew 3Scaling Options Help

Hode Qe Channel=: 1.2
= (F3): 240 > .Cnmp;ES;(E?};

L34
1 Stn;age:. . 3 gseﬁ

current sample rate

DI-149 USB Data Acquisition Starter Kit
Specify a per channel sample rate:

1 In the Edit menu click on Sample Rate.... This displays the sample rate dialog box: Click icon for Demeo

Sample Rate E|
Channels enabled = 8
Total Sample Rate = 240

Set | Maximum rate/channel = 30

Set | Minimum ratefchannel = 0009156

Sample Rate/Channel = |3I]

0OK Cancel

2. Enter the desired sample rate per channel in samples per second in the Sample Rate/Channel text box. Click on
a Set button to have WinDag automatically set your per channel sample rate to the maximum or minimum
allowed for your throughput rate. Please Note: WinDag/Lite will display a total sample throughput rate of
10,000 Hz (or 1250 Hz per channel) but will not record at rates over 240 Hz throughput (30 Hz per channel). You
must purchase WinDag/HS to record at rates over 240 Hz throughput.

3. Click OK or press the ENTER key.

WINDAQ Acquisition
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The sample rate per channel is displayed in the lower left corner of the window as S/s/CHAN: (samples per second

per channel).
A= R T L A A
‘ ~10.000 b : SR : : L

b= = CHaN: 30 “=ec DIV 0667 Status. SET_UF

sample rate per channel

All Other Products
Specify a throughput rate:

1. Inthe Edit menu click on Sample Rate... . This displays the sample rate dialog box. Chck it T Detan

Sample Rate §|

Input Buffer Size in KiloBytes = 0

Disk Buffer Size in KiloBytes = b4

Sample Rate = |24|]

OK Cancel

2. Enter the desired data throughput rate (or total scanning rate) in samples per second in the Sample Rate dialog
box.

3. Click OK or press the ENTER key.

WINDAQ Acquisition automatically allocates the correct amount of buffer space needed for the sample rate specified.
The Input Buffer Size and Disk Buffer Size values display for informational purposes only.

Keep in mind that sample rate equals throughput rate. The current sample rate per channel (obtained by dividing the
selected sample throughput rate by the number of channels enabled) displays in the lower left corner of the window as
S/sICHAN: (samples per second per channel).

sec DIV 0,333 Status. SET_UF

sample rate per channel

You may specify/configure any sample rate that the hardware/software allows but you might not achieve the specific
rate desired. For example (due to the inability to divide the master clock in a manner that results in an even-numbered
quotient), you may see a sample rate of 2999.63 when you entered 3000.

WINDAQ/Pro+

Because WINDAQ/Pro+ recording software has the ability to sample different channels at different rates, it calculates
the sample throughput rate differently than WINDAGQ/Lite or WINDAQ/Pro recording software. To calculate a total
sample throughput rate for WINDAQ/Pro+ software, multiply the number of channels to record by the rate of the fast-
est channel. For example, suppose you want to record four channels of data, one at 2kHz and the other three at 20Hz.
The sample throughput rate in this case would be 8kHz (4 channels x 2kHz = 8kHz).

WINDAQ Acquisition
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Step 4 Specifying Gain and Measurement Range
Note: Some Products do not support this feature.

Choose a gain factor (varies by instrument) to get the best possible measurement resolution for your
signals. A gain of 1 (unity) provides the widest measurement range possible on any given instru-
ment (default). For example, if using a DI-720—this instrument features a maximum analog measurement range of
+10 volts and programmable gain factors of 1, 2, 4, and 8—a gain of 1 (gain factor = 1) makes the full scale measure-
ment range equal to +10 volts. However, at a gain of 2, the full scale measurement range equals £5 volts. The full
scale measurement range gets even smaller for gain factors of 4 (range = £2.5 volts) and 8 (range = £1.25 volts).

22 DI-154 Acquisitior

File Edit Wiew Scaling

Mode: O=cill
So= (Fah: 240

Click icon for Demo

10.000 i

-__,.r-""r :
Full Scale _— o
hMeasurement 4990 :]iit
10,000 .ué_”

If the signals you plan to record need the wide measurement range that a gain of 1 provides, then skip this step. Oth-
erwise, continue with this step to select a higher gain factor (thus narrower measurement range) for the best possible
measurement resolution.

1. Click the left mouse button in the unselected channel’s annotation margin to select an analog channel for gain
adjustment. A box will surround the Variable Waveform Assignment Indicator of the channel selected. The Vari-
able Waveform Assignment Indicator displays the window number and the channel assigned to that window
(X=Y: X=window number; Y=channel number).

X DI-700 - WinDag/Lite

File Edit Wew Scalng O

Mode: O=cill
Sz (F3): 244 .1406

10,000
Unselected Channel
N
1=1 olt
Yariable Waverorm
Assignment Indicator —10.000 -
10.000 o

=elected Channel

01 .
oit T

click anywhere in shaded
10 .opgp o areato select a channel

WINDAQ Acquisition
14


http://www.dataq.com/multimedia/windaq-fast-start/gain/index.html
http://www.dataq.com/multimedia/windaq-fast-start/gain/index.html

WINDAQ Software User’s Manual

2. Click on Channel Settings... in the Edit menu. This displays the Channel Settings dialog box:

Channel 1 Settings E|
Gain  -FSVolt  +FS Volt Acguisition Method
1 -10.000 10.000
-
10 1.0000  1.0000 Average
100 -.10000 .10000 Last Point

1000 -.010000 010000
Maximum

o
~

" Minimum
" BMS

~

Frequency

Input Type
* Linear
~

~

OK Reset Cal. Cancel ‘

The Channel Settings dialog box displays the hardware-dependent gain factors and equivalent plus and minus full
scale voltages that result from selecting that gain factor—voltages vary by hardware device.

3. Click on the desired gain factor.
4. Click OK or press the ENTER key.

Plus/Minus full-scale annotation adjusts to reflect the application of various gain factors. You cannot adjust gain fac-
tor while in RECORD maode. See the Channel Settings Function in the Help File for complete details regarding chan-
nel settings.

Step 5 Converting Volts to Engineering Units

EU Settings allows you to view and record waveform data in significant engineering units—con-
verting measurements from volts to a more meaningful unit of measure. WINDAQ can scale, anno-
tate, and display data in PSI, RPM, Ibs, ft/s, or whatever engineering unit you specify. Click icon for Demo

1. Click the left mouse button in the unselected channel’s annotation margin to select an analog channel for gain
adjustment. A box will surround the Variable Waveform Assignment Indicator of the channel selected. The Vari-
able Waveform Assignment Indicator displays the window number and the channel assigned to that window
(X=Y: X=window number; Y=channel number).

WINDAQ Acquisition
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X DI-700 - WinDag/Lite

File Edit Wew Scalng O

Mode: O=cill
Sz (F3): 244 .1406

10,000
Unselected Channel
Ol
1=1 olt
Yariable Waverorm
Assignment Indicator —10.000 -
10.000 L

=elected Channel

01
olt
ot tlick anywhere in shaded

10 .opgp o areato select a channel

2. Click on Engineering Unit Settings... in the Edit menu.

Channel 1 Engineering Unit Settings

Volts EU EUTag @]
Upper Level /| [10.000 = 10.000
Lower Level /*|[.000 = [.000 =
‘ 0K Next ‘ Set Dﬁset‘ Cancel ‘

3. When the relationship of volts to engineering units is known, define the relationship in the provided text boxes.
For example, you know 5V equals 1500 PSI and 0V equals 0 PSI using your sensor. Enter the Volts and EU val-
ues in the appropriate text boxes as shown:

Channel 1 Engineering Unit Settings

Volts EU EUTag @
Upper Level | [5 = [1500
Lower Level /*|[.000 = [.000 =
‘ 0K Next ‘ Set Dﬁset‘ Cancel ‘

4. Use the eyedroppers when you do not know the relationship of volts output from the sensor versus engineering
units. Click either eyedropper to take a sample of the data in volts when a known engineering unit value is
applied to the signal input (or found at the cursor position when using WinDag Playback Software) for that chan-
nel. The sample value will appear in the Volts text box. Enter the corresponding engineering units in the EU text

WINDAQ Acquisition
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box. Perform the same operation on the opposite end of the range. It is best to sample as close as possible to the
upper and lower limits of your intended measurements to ensure accurate readings.

Click OK to save the settings. Note that screen scaling for the adjusted channel may change but can be redefined
by selecting LIMITS... from the SCALING pull-down menu. Click Next to save the settings and open the dialog
box for the next channel. Click Previous to save the settings and open the dialog box for the previous channel.
Cancel exits the box without saving any settings.

You can revert to the previous EU settings at any time by using the Reset EU command in the Edit menu. Use the Set
Offset button to offset the waveform (refer to the help files for more information).

Step 6 Recording Waveforms to Disk
The Record function on the File menu initiates recording to disk. To begin waveform recording:

1.

Click on Record in the File menu or press F4. This displays the Open File dialog box. Specify click icon for Dema
a file name to create a new file or open an existing file to append to it. To create a new file you must specify a
maximum file size. To append an existing file you must specify how much additional data to add to it. In either
case, you can specify file size in kilobytes or recording time (where sample rate determines the file size). Exper-
iment with different file sizes, sample rates, and recording time to get the desired result. Entering information
into the File Size box and pressing the TAB key will display the corresponding Recording Time in the Recording
Time box and vice versa.

File Size [X]

File Size in KiloBytes = |?2I]

At a sample rate of 240 5fs,
Recording Time in [hours:min:]sec = |I]:25:34

1] 4 Cancel

Enter the desired file size or accept the default.

Click OK or press the Enter key to close the dialog box and begin recording to disk. WINDAQ enters RECORD
mode and simultaneously digitizes, displays on your monitor, and streams analog channel data to disk. The Sta-
tus: field in the bottom annotation line indicates RECORD.

WINDAQ Acquisition
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22 DI-154 Acquisition - test. WDO

File Edit

Mode :
So= (Fa):

Wiew

D=zc1ll
240

Scaling  Options

Channels:

Help

1.2

10.000

171

Volt

—10.000

Compres=s(F7): 1

Storage: b.Z2% used

10.000

3.330

2=2 Volt

=10.000

Sz CHAN

120

“=ecDIV. 0.167

Statusf

—10.000

Actively Recording to Disk

Click on Stop in the File menu or press Control + F4 to pause recording. This suspends data storage to disk, but the
real time display remains active. The Status: field in the bottom annotation line indicates STBY.

S = CHAN

121

“sec DIV 0,167

BN
Status=:({STEY

Recording has been stopped
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The “Storage:” field of the status bar displays the amount of file space consumed as a percentage of total file space
consumed.

Z2/D1-154 Acquisition - test. WDQ
File Edit Mew 3Scaling ©pktions Help

Mode: O=cill Channel=: 1.2
: Camp:ess{F?}: 1 _ Storage: (ETEZ_E;;E)

File space consurned

You may start and stop recording as many times as desired. When the target data file has filled, data acquisition to
disk will cease, the “Storage:” field of the status bar will display “100% used” and the Status: field of the status bar
will display FILE FULL.

2% DI-154 Acquisition - test. WDQ

File Edit Wiew Scaling Options Help
Hode: C=cill Channel=s: 1.2
So= (F3): 240 Compress(F7): 1 torage: 100 . 0% use
oo0 | T
4.9490
Volt
~10.000 ~ DataFile Full Indicatio
10,000 R oo
3.335
2=2 Volt
-10.000 IR IR N
So=-CHAH: 120 zec-DIV: 0.167 1Eiatus: FILE FUULL z

Each time recording is activated, WINDAQ inserts an event marker into the data stream. This creates acquisition break
points viewable in WINDAQ Waveform Browser Playback Software and also functions as a time and date stamp.

WINDAQ Acquisition
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Additional Data Acquisition Features

Some products do not support these features—see the help files for complete details. WINDAQ Data Acquisition Soft-
ware offers these functions and much, much more.

Event Markers

Event Markers with comments allow you to add time and date stamped comments to the file while recording. Use
event markers to mark an event or flag an uncommon occurrence in the data stream going to disk—providing a com-
plete record of what happened and why. You automatically insert event markers in the data stream each time you acti-
vate the RECORD operating mode. These event markers get tagged with a time and date stamp that allows
correlation with any point in a recorded waveform file and a precise date and time of occurrence (to the nearest sec-
ond). After the data acquisition session, WINDAQ Waveform Browser Playback Software allows you to automatically
search and move to the point in the data file where the event markers were placed during data acquisition (refer to the
Search-For-Event function of the WiINDAQ Waveform Browser Help File for more details). Refer to the Event Marker
Function in the Acquisition Help Files for more information.

Triggered Sweep Display

Triggered Sweep Display allows you to trigger the real time display so that periodic waveforms appear stationary. Set
trigger conditions (such as channel, level, and slope) that define the starting point for displaying the waveform on-
screen. WINDAQ displays the waveform only when data meets the trigger conditions, producing a stable display eas-
ily measured or compared to other waveforms since it starts at the same point on the screen with every sweep. The
single sweep remains on the screen until waveform data again meets trigger conditions. See Display Mode Selection
in the Help Files for more information.

Triggered Mode (as supported by your hardware)

Set trigger conditions for recording data to disk. The number of pre and post trigger data points allows the user to
frame an event to determine cause and effect. Set hysteresis for more reliable triggering on noisy signals. The trigger
point can also be “stamped” with a vertical line in the data file. See Acquisition Triggering in the Help Files for more
information.

Reference Files

Reference Files allow you to define an unlimited number of default states. Specify any data acquisition file as the “set
up” for a new file. All data acquisition parameters (including number of channels, channel type, scaling constants,
engineering units, display format, compression, display mode, gain, etc.) from the previously recorded file become
the parameters for the new data file. See Open Reference File in the Help Files for more information.

User Annotation

User Annotation allows you to display a label (up to 30 characters) for each displayed channel. The label “rides” with
the channel data and WINDAQ writes the annotation to the data file along with the acquired waveform. See User
Channel Annotation in the Help Files for more information.

WINDAQ Acquisition
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4. WINDAQ Waveform Browser

WINDAQ Waveform Browser (WWB) interprets and analyzes data during or after acquisition to disk. Make timing
and amplitude measurements, review event markers, overlap waveforms to examine interdependencies, cut and paste
portions of the waveform for export, and do all forms of interpretive analysis.

Follow the basic steps presented in this Chapter for a fast start to your first waveform playback and analysis session.
These fast start steps outline the condensed procedure for reviewing waveforms. You will perform most of these func-
tions every time you review data with WINDAQ Waveform Browser.

To run WINDAQ Waveform Browser software, click or double-click the WWB icon or select “Browse” in the File
menu of the Acquisition software. Data acquisition does not need to be stopped to open and view the contents of a
WINDAQ file. This allows interpretive analysis and measurement calculations while simultaneously recording data.

Help Files

For a complete description of all software functions, see the context-sensitive Help Files. To access the context sensi-
tive help either highlight a menu item and press F1 (this will take you directly to help regarding that menu item) or go
to the Help menu and click on Contents. The Help Files elaborate and detail the functions in this Chapter and contain
detailed descriptions of each additional function available in the WINDAQ Waveform Browser software. After you
have become familiar with the functions described here, take some time to look over the rest of the functions detailed
in the Help Files.

Fast Start

Step 1 Moving Around in the Data File

Moving Coarsely Through the Data File with the Scroll Bar

WINDAQ Waveform Browser software allows for smooth scrolling (panning) or paging of wave-  Click icon for Deme
forms in either a right-to-left (positive time) or left-to-right (negative time) direction. The horizontal scroll bar at the
bottom of the WINDAQ window controls waveform scrolling. With it, you can move from one part of the waveform
file to another. For optimum scrolling speed, position the WINDAQ Waveform Browser window entirely on the
screen.

Click this area to scroll one screen width at a time
Drag slider box to scroll long distances. \

[t A[a” ! _»{+]

Click scroll arrows to scroll 16 pixels at a time:

The horizontal scroll bar has the following functions:

»  Click the left or right scroll arrow to scroll through the waveform 16 pixels at a time. Click and hold either
scroll arrow to continue scrolling to the beginning or end of the file.

*  Click anywhere in the horizontal scroll bar on either side of the slider box to scroll the waveform one screen-
width toward the beginning or end of the data file. Hold down the left mouse button to scroll rapidly until the
slider box reaches the mouse pointer.

WINDAQ Waveform Browser
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Moving to a Single Point Using the Cursor
Click in the bottom annotation line to move the cursor directly above the point clicked. Click and drag in the bottom
annotation line to allow the user to move the cursor to any single point on the screen.

cursar
hottom
annatatian 1002000
Iine ﬂ.]I:II] SEC[TBE) off SEC{TH) 0. & SEOF C L.'lE-I]E—Bﬂ 10:26:25 4.
] i) ¥

click here to move the c‘ursur directly above

You may also navigate using left and right arrow keys (if using the number key pad be sure num lock is off).

Note: Using a floppy disk based data file as opposed to a hard disk based file will adversely affect the maximum
speed of waveform travel in either direction. To achieve maximum waveform scroll speed for your particular com-
puter, copy the file to your hard drive.

Step 2 Time and Date Display

View the Time and Date Display on the right-hand side of the bottom annotation line.

Click icon for Demao

W WINDAQ - SAMPLE.WDO

File Edit View Search Transform XY RERGGLEN Help
5.0000 ‘ i v Data Cursor Alt+F2
2N v Data Display F2
2.7661 | X | v Limit & Frequency Display Al+L
1=1 Volt : Units/Division Ctrl+Shift+U
T L i j Acquisition Assignments  Chri+Shift+A
— g g g g g — - v Enable Live Display F3
[ P Select Live Display 3
9326 i peeed Enable Time Marker F4
222 Volt /\,_;—v—/\,__l,-r— iieoc:::marker Display . »
: _ Time and Date
-5 .0000 g N Cursor Time Ctri+Shift+R : .
5.0000 Start Time Ctri+B T i DISplay
£ o ] End Time Ctrl+Shift+8 : 0 pti ons
-. 6714 i ] Time,/Division Chri+D
323 Volt b
g : §echig v Event Marks Alk+F8
€ 0000 L i v Grids Alt+G
—5' CEDﬁ-ﬂ ——*—-——-—— —— — Grid Spacing... Ctri+G

4=4 Volt

0024 ___J K

| P

\F |
-5.0000 ' > Display

|DATA 1.0ﬂ SEC(TEF) off SEC(TH) 5.2 EOF@ : 11-16-94 17:59:32 80
4 »

Toggle the display between Start Time, End Time, Cursor Time, and Time/Division in the Options menu.

Start Time
The Start Time displays the date and time the file was opened for acquisition. Click on Start Time in the Options
menu. An “S” displays prior to the Start Time.

-5 . UUuu I 1 I | | T NN S B e I
DATA 1.032 SEC(TBF) off SEC(TH) £.2 EOKS: 11-16-94 17:59:31 80
‘ e BRIy J

Start Time Enabled 7~
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End Time
The End Time displays the date and time the file was closed for acquisition. Click on End Time in the Options

menu. An “E” displays prior to the End Time.

—>.0000 f 1 I 1 : | I ! 1 - it
DATA 1.032 SEC(TBF) off SEC(TH) 5.2 %E E: 11-16-94 17:59:51 Bil
I i »

End Time Enabled

Cursor Time
The Cursor Time displays the date and time at the current cursor position. Click on Cursor Time in the Options

menu. A “C” displays prior to the Cursor Time.
-5.0000

] I | ! I B L 2 e el ) O e 1
DATA 5._6|84 SEC(TBF) _| off SEC(TM) 28.4 “EMg _C: 11-16-94 17:59:36 Bil
4 »

Cursor Time Enabled

Time/Division

The Time/Division displays the time per screen grid division. Click on Time/Division in the Options menu. A “T”

displays prior to the Time/Division.

o =5.0000 e T e R 1

DATA Sjﬂq SEC(TBF) off SEC(TM) 28.4 “EQ J
4 »

080 SEC/DIV

Time/Division Enabled/

Step 3 Making Waveform Measurements with the Cursor

Selecting a Channel

Select a channel in WINDAQ Waveform Browser just as you would in the WINDAQ Acquisition Click icon for Dema
Software i.e, click in the desired channel’s left/right annotation margin. A box will surround the Variable Waveform
Assignment Indicator of the selected channel. The Variable Waveform Assignment Indicator displays the window
number and the channel assigned to that window (X=Y: X=window number; Y=channel number).

5% WINDAQ - SAM
Elle Edit View Se
5.0000 [ unselected

Variable Waveform channel

Assignment Indicator

=5.0000

[ 500000 selected
channel
<. 9 7
2% click anywhere in shaded
_c pogo area to select a channel

The Data Cursor
The Data Cursor allows annotation of waveform values at the point of waveform/cursor, or waveform/base line inter-

section. These values appear in the left/right annotation margin next to the Variable Waveform Assignment indicator.
Enable the data display waveform annotation option before toggling waveform/cursor or waveform/base line values.
With the data display option enabled, click on Data Cursor in the Options menu. A check mark next to Data Cursor
indicates enabled status. Click anywhere in the bottom annotation line to activate the data cursor. Click directly under
the data cursor in the bottom annotation line to disable it and enable waveform/base line intersection point values. As

WINDAQ Waveform Browser
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the following illustration shows, when cursor oriented waveform data is enabled, the cursor mode designator at the
bottom of the screen indicates DATA. When base line oriented waveform data is enabled, the cursor mode designator
indicates BASE.

point of intersection

W WINDAQ - SAMPLE.WDO
File Edt View Search
5.0000 |

AT

C’iﬁ"}" = 'Ei'"/’.’E‘OF’"E':""'i'i—'ié—é'af"‘i’??is'é‘:"ii' 080
13
s cursor

The annotated waveform value outputs either the raw waveform voltage or the waveform voltage converted into engi-
neering units (if calibrated).

waveform value

at point of
intersection \

cursor mode
designator

'.'é"ﬁ'él SEC(TEF)  of INGE

When in BASE mode use the Page Up and Page Down keys to change the baseline value of a selected channel. This
shifts the waveform up or down on the screen. The upper and lower chart edge values change to center the baseline
value.

TSIEELE %8 WINDAQ - SAMPLE.WDO =13
edge value™ -.Eil\e Edit View Search Scaling Transform XY Options Help
*9 0414

' baseline moved to top
of waveform

Sy fosasd \ i Jessofnased vorfrunelfossfunnad Beesefuensifres ; frased
IEASE 1.0144| SEC(TEF) off SEC(TH) 5.2 ¥EOF C: 11-16-94 17:59:32 .080
4 »

The baseline value outputs either the raw waveform voltage or the waveform voltage converted into engineering units
if calibrated.

baseline
value

\4 0417

lower chart Yolt
edge value

cursor mode
designator

Moving the Cursor to the highest peak

Select a channel in which to find the highest point. Click on Peak on Screen in the Search menu or double click the
left mouse button anywhere in the bottom annotation line. This moves the cursor to the highest waveform peak dis-
played on the screen for the selected channel.

Moving the Cursor to the lowest valley

Select a channel in which to find the lowest point. Click on Valley on Screen in the Search menu or double click the
right mouse button anywhere in the bottom annotation line. This moves the cursor to the lowest waveform valley dis-
played on the screen for the selected channel.

WINDAQ Waveform Browser
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Moving the Cursor to the Center of the Screen

Click on Center Cursor in the Search menu or click the right mouse button in the bottom annotation line. This
moves the cursor to the enter of the screen. If your computer’s Scroll Lock function is enabled, the waveform will
move to the center of the screen along with the cursor.

Step 4 Getting a Bird’s Eye View of All the Data or a Portion of the Data

WINDAQ allows compression of data to display a whole file on-screen or display portions of data in
one screen-width. Click on Compression... in the Edit menu to access waveform compression
options. This displays the waveform compression dialog box. Click icon for Dema

Compression @

Compression =|ﬁ

Compressed Data Display:
+ MID " MIN " MAX " MxMn

OK 1 | Maximum Cancel

Compressing all Data

To compress an entire file into one window-width click on the Maximum button in the compression dialog box. To
fully uncompress the file click on the 1 button in the compression dialog box. The cursor position in maximum com-
pressed mode will become the center of the screen whenever lowering compression.

Compressing to a Ratio

The selected waveform compression ratio outputs in the Compression= text box. The Compression ratio equals the
number of data points evaluated for a min/max value for each enabled channel. For example, if the compression ratio
equals twenty, then twenty data points are evaluated to plot a min/max point. This ratio can range from -10 to what-
ever value required to compress the entire file on the screen (Maximum). Entering negative values in the Compres-
sion text box will expand the waveform. To find the maximum possible compression value: Fully compress the
waveform (Maximum); then re-access the compression dialog box (Edit > Compression...)—the Compression= text
box displays the maximum possible compression value. To increase or decrease the compression ratio enter the
desired number. If you choose a compression value that is too large, an “Invalid Compression” message box will
appear. Click OK or press ENTER to clear the message box and try a smaller compression value.

Cursor Mode Control (Mid/Min/Max/MxMn) for compressed displays

The waveform compression function operates by accumulating x number of waveform samples (where x equals the
compression ratio). WINDAQ calculates these values and displays a min/max line where the end points of the line
equal the absolute minimum and maximum values detected for the sample group. The cursor mode control allows
you to specify the desired value to report as either the minimum (MIN), maximum (MAX), mid point (MID), or max-
imum and minimum values (MxMn). To select the desired line segment reporting method click the desired option
button and click OK.

The currently active cursor mode displays at the bottom of the screen where the DATA annotation is replaced by
MIN, MAX, MID, or MxMn (default = MID). Both maximum and minimum values (separated by a slash, in the left/
right annotation margin) are displayed in MxMn mode.

Step 5 Making Statistics Measurements

Extract and save statistics in text format for a specified section of any single waveform or for all

waveforms in a file. This is a quick and easy way to get just the data desired rather than looking at

all the numbers from a complete file. Click icon for Dema

WINDAQ Waveform Browser
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1. Select a channel by clicking in the desired channel’s left/right annotation margin. If you did not select a channel,

the Open Statistics File dialog box will open allowing you to save the statistics for all channels in a spreadsheet
or text format.

2. Position the cursor at the beginning of the desired range.

3. Press F4 or select Enable Time Marker in the Options menu to enable the time marker. This will place a check
mark next to Enable Time Marker in the Options menu and will also show an increment of time in the bottom
annotation line by the Time Marker (TM). When initially enabled it will show “.00 SEC(TM).” When disabled it

will read “off SEC(TM).” The Time marker display format may be changed by selecting Select Marker Display
in the Options menu.

5% WINDAO - Automobile Transmission. WDO 5E WINDAQ - Automobile Transmission. WDQ

File Edit \iew Search Scaling Transform  ¥Y  Options  Help Eile Edit WView 3Zearch Scaling Transform  xY Options Help
0000 0. L I T 700.0 ; EOUURE I TR :

1=3 TS .

: Time Time
"""" ; harker hlarker
_gg.g i ./ Disahled -50. v Enabled

DATA 115.|f33 SEC({TEF) off SEC(TH) IDATA 115.|b3 SEC(TEF) 00 SEC(TH;
— 4

WINDAQ Waveform Browser
26



WINDAQ Software User’s Manual

4. Position the cursor at the end of the desired range. Click on Statistics in the View menu. If a channel has not been
selected, the Open Statistics File dialog box will open allowing you to save all statistics for all channels to a text
or spreadsheet file. If a channel has been selected, the Statistics window opens.

UNITS "AMPS"
CHANNEL &# 2
# OF POINTS 334
MEAN 1.3921E 03
STD DEVIATION 6.2041E 02
MINIMUM 2.1057E 02
MEDIAN 1.2428E 03
MAXIMUM 3.0972E 03
RMS 1.5237E 03
SUM 4.6496E 05
SUM OF SQUARES 7.7545E 08
VARIANCE 3.8491E 05
SKEWNESS 7.2185E-01
SLOPE 5.6651E 01
AREA 3.0999E 04
START POINT TBF 16.53
END POINT TBF 38.74
FILE DC Drive Systems 3.WDQ
‘ Open New File... | To Clipboard |
Next ‘ Previous | [ Cancel |

The Statistics window will display the statistics for the currently selected channel including significant engineering
units, channel number, the number of samples the statistics are derived from, and the file name, as well as the mean,
deviation, minimum, slope, area, and position in the file. Use the Next and Previous buttons to view other channels in
the file. Statistics will work with any level of compression—even fully compressed.

The To Clipboard button allows the user to save the current statistics window to the Windows clipboard. This data
can then be “pasted” (CTRL + v) into a file. The Open New File... button will save data to file (if you select a channel
it will save only that channel—if you do not select a channel it will save ALL channels’ data). Save data in spread-
sheet format (with comma delimiters) or text format. The Write to File... button allows you append an existing file.

Step 6 Exporting to Excel

Use the Save As... command in the File menu to export a user-specified range of data from an exist-

ing data file to an Excel file.
Click icon for Demao

1. Select the copy range (all data for each channel lying between the time marker and the cursor):

WINDAQ Waveform Browser
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a. Position the cursor at the beginning of the desired range.

cursor placed at
beginning of

5 WINDAQ - SAMPLE.WDQ

File Edit View Search

) Transform 2xY Options Help

desired range

Time Marker
disabled

-5.0000

DATA

_BSZiSEC(TEF)

P off SEC(TM)

4.3 XEOF C: 11-16-94

17:59:31 .080
»

b. Press F4 or select Enable Time Marker in the Options menu to enable the time marker. This will place a
check mark next to Enable Time Marker in the Options menu and will also show an increment of time in the
bottom annotation line by the Time Marker (TM). When initially enabled it will show “.00 SEC(TM).”
When disabled it will read “off SEC(TM).” The Time marker display format may be changed by selecting
Select Marker Display in the Options menu.

¢. Position the cursor at the end of the desired range. Note: Shading shown below is for demonstration pur-
poses only. Shading does not appear in WINDAQ Playback Software.

i WINDAQ - SAMPLE.WDO

[ 50000

-3.9893
1 Volt

1

=5.0000

File Edit WView Search

Transform %Y Options Help

EEX

start of desired

IDATA 2 I8 312 0I SEC(TBF)
4

242 SHP(TH) YF

9.1 %EOF C:

R T P

11-16-94 17:59:32 .080

cursor at end of
- desired range

shaded region
— is entire
desired range

enable Time
— Marker (F4)
prior to placing
cursor at end of
desired range
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2.

Click on Save As... in the File menu. This displays the Save As dialog box.

select Visible channel only to export JUST
the waveforms displayed on screen

fSave in [._J DATAQ j - ¥ E9- ¥ Visible channels only

[ EExcelProgram [T Output all values when compressed
type in the j t;bwew 1) ASCII (sequential)
“ csv” file 2] Binary (with CODAS header)
extension \ | 3) Binary [without CODAS headet)

4)ASYSTIANT)
5] Spreadsheet print [CSY]
E) Deferred Hard Copy

= 7) DADISP
File name: be: tcs\.i =
I u 8) CALC
Save as lype: |Save As Files (".csv) ) EASYEST LX or AG
A nSoft DAC

select option 5 £

Select the file storage format option 5) Spreadsheet print (CSV). The file storage format selections appear on the
right side of the dialog box. A description of each data storage format is included in the Help Files for the
WINDAQ Waveform Browser software.

Enter a file name in the File name dialog box. Include “.csv” as the file extension in the file name. For example,
enter “test.csv” into the file name dialog box. Click on Save to export the data—this copies the data within your
selected range and from every channel in the file to the specified data file. To save only the channels displayed
on-screen select the Visible channels only box in the top right hand portion of the Save As dialog box. To export
specific channels, see the Extract Channels function in the Help Files.

The Spreadsheet Comments dialog box allows you to export annotations from the WWB file and allows you to
add new comments. Click in the appropriate check box to transfer Sample Rate, Comments, User Annotation,
Engineering Units, Relative Time, or Event Marks. After selecting the desired options and adding comments,
click the OK button to close the dialog box and save the file.

Spreadsheet Comments @

Samples per sec. = 250{1

Spreadsheet Comment 1

|lesl‘|

]

Spreadsheet Comment 2

v Sample Rate v Comments ¥ User Annotation

¥ Engineering Units ™ Relative Time Channel | Event Marks

coer_|
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6. The file will have an Excel icon—double-click on the file to open it in Excel.

7. Convert data from scientific notation by changing the format of the cells to “Number” format. Highlight the data,
in the Format menu click on Cells... then choose the desired format.

E4 Microsoft Excel - test

&) Fle Edt View Insert |Fgrmat Tools Data Window Help Adobe FOF

DeEe a8l &=

- Row ]
tEY ki -
Al e Sheet »
D E

| 1 |Samples persec. =.  AutoFormat...
% testl Conditional Formatting. ..
I Sine Wave 2
5 [volt
6 | 3.99E+00
7 | -3 96E+00
8 | -3 93E+00 Format Cells
B 3.90E+00
10| -3 BEEH0) tumber | Algnment | Font | Border | Patterns | Protection |
L 3.81E+00 Category: Sample
12 3;35% Samples per sec. = 250/1

13 -3. Nurmnber
E -3 60E+00)| g‘;roet.rmvt:u Decimal places: [2 3‘
15 -351E+00 Date
|16 | -3.41E+00) ;xﬁm [ Use 1000 Separator (,)

17 -3.31E+00 Negative numbers:
18] 3 20E+400 Sconthc
1 19| -3.07E+00 Text
20 -2 93E+00 R oo ~
21 2.78E+00
22 2.63E+00

23 -2 47E+00 Number ks used for general display of numbers. Currency and Accounting
24 | -2 31E+00| offer specialized formatting for monetary value.
25| 2 15E+00)
26 | 1.98E+00)

27 -1.60E+00
78| -1 B1E+00 [ o ] cone
29| -1.42E+00
30 1.23E+00)
31 1.04E+00)
132 -8 42E01
133 -6 42E-01
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8.

9.

Manipulate your data using any Excel function. Click on Chart... in the Insert menu to create a graphical repre-

sentation of your data.

&) Fle Edit View | [nsert Format Tools Data Window Help Adobe PDF

DeE & ¢ Bows - @ &4 3
Columns
ﬁ'j %’:ﬁﬁ Worksheet
2
Aﬂ — c D E

1 |Samples per ¢ fx Eunction...

2 |testl Name »

3 {

4 |Sine Wave Picture »

5 |Volt @ Hyperink...  Ctri+K

6 ¥
7 e
(8| 393
1 9 | -3.90 Chart Wizard - Step 1 of 4 - Chart Type
10 -3.86

1 -3.81 Standard Types | Custom Types |
12 -3.75 Chart type: Chart sub-type:
13 -368 Column =

14 -3.60 Bt X o
15 351 MN BN
16| 3.41 :
17 -3.31 L/\’ [
18 -3.20 SN Ny
19 -3.07 . e |
20 293 p——
= s

22 -263
23| 247 =
__gf‘_ -2.31 Line. Displays trend over time or
125 -2.15 categories,
26 -1.98
i i [ oo s rtito e sonpe |
2 12 e e o
ET 10

Choosing a Line chart will output a chart identical to the waveform exported from WINDAQ Waveform Browser.

-3.99
-3.96
-3.93
-3.90
-3.86
-3.81
-3.75
-3.68
-3.60
-3.51
-3.41
-3.31
-3.20
-3.07
-2.93
-2.78
-2.63
-2.47
-2.31
-2.15
-1.98
-1.80
-1.61
-1.42
-1.23
-1.04
-0.84

5.00

4.00 A
3.00 A
2.00 4
1.00 A
= (.00

15

1007
-2.00 A
3.00
-4.00
500

43

57

71
127
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Additional Playback Features

X-Y plotting

Plot one channel versus another. Plot any two amplitude/time (Y-T) oriented waveforms versus each other - one chan-
nel designated as the X-axis and one as the Y-axis. Make analytical measurements on the X-Y plot including measure
excursion, slope, and area. Static and Dynamic generation of X-Y plots are possible. See X-Y Plotting Operations in
the Help Files for more information.

FFT and DFT utilities

Perform waveform frequency analysis functions using Fourier Transform Operations. The Fast Fourier Transform
(FFT) method is ideally suited for waveforms having a similar cyclic repetition. Use the Discrete Fourier Transform
operation to select a portion of the waveform more accurately than the FFT. See Fourier Transform Operations in the
Help Files for more information.

Event Markers

Display the list of event markers and comments enabled during acquisition. Automatically locate event markers
enabled during acquisition, display the date and time at the cursor position, quickly vector to any part of the data file,
and enable or disable event marker display. Edit, delete, and add Event Markers in the data file. See Event Mark Edit-
ing and Search-For-Event in the Help Files for more information.

WINDAQ Waveform Browser offers these features and much, much more.

WINDAQ Waveform Browser
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5. ActiveX Controls

Active X Controls eliminate lines of code from your program by having an already-made, tested, and defined func-
tion. Combine multiple ActiveX controls to perform a multitude of functions. In fact, you can combine Active X con-
trols from any combination of vendors. Refer to numerous lines of code that have already been tested and are ready to
go to work for you in just one line of code.

ActiveX controls have three types of functions: properties, methods and events. Properties are the attributes of the
control. They describe the appearance and operation of the control. Methods are function calls inside the control that
allow information about the control to be sent or received. Events are notifications generated by a control in response
to some particular occurrence.

DATAQ ActiveX Controls support the following products: DI-148U, DI-150, DI-151, DI-154RS, DI-158 Series, DI-
190, DI-194RS, DI-195B, DI-4xx products, DI-5xx products, DI-7xx products, DI1-5001.

Help Files

For a complete description of all properties, methods, and events, see the context-sensitive Help Files. To access the
context sensitive help select a control or a specific property, method, or event, and press F1 (this will take you directly
to help regarding that control, property, method, or event). The Help Files elaborate and detail each property, method,
and event and provide sample program coding to help get you started.

Accessing ActiveX Controls

ActiveX controls are installed when WINDAQ is installed and can be accessed in any application that supports them.
For example, it takes two steps to start using ActiveX controls in Visual Basic:

1. Right click on the tool bar and select “Components” from the pop-up menu. This opens the Components Win-
dow.

2. Check the boxes in front of the five DATAQ Instruments components (DatagFile, DataqSdk, DatagSerial,
DQChart, and WinDag). Then click “OK.”

. Project] - Form

B o~ | - ;
. Contrals | Demgnersl Inzertable I:Il:u|ects|
.

[ axBrowse ;I
[(]#wckrl32 OLE Control rmodule J

Zomponents. .. [Tbpecctl 1.0 Type Library

add Tah [br549 OLE Control madule

= o [ oy W INDOW S| SYSTEM TDE, OCy,

| v Docksble [ <dlg
) [issEde
Hide

[1d2hframe 1.0 Type Library

DATAG Instruments DatagFile Control
DATAD Instruments DatagSdk Control
DaTAQ Instruments Datag3erial Conkrol
DATAG Instruments DOChart Conkrol

DATAC Instruments WinCag Control
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You will see the ActiveX control symbols on your tool bar.

=
@ L g

2/ @ [ oee @

Active =
Controls

Double-click on the symbol to apply one to your form. To access the help files, select the control or select a specific
property, method or event and press the F1 key.

DatagFile

DatagFile is comprised of two components: WriteDatagFile and ReadDatagFile.

WriteDataqFile W WriteDatagFile Control

Use WriteDatagFile to create WINDAQ-compatible files. This control ensures that the files created by your program
may be used with WINDAQ Waveform Browser software.

Features of WriteDatagFile include:
»  File manipulation utilities that allow controlled access to data.
»  +/- Full-scale definitions per channel in engineering units.
»  Sample rate throughput definition that is used by WINDAQ browser software for timing measurements.
WriteDatagFile has the following limitations:
»  Supports only regular WINDAGQ files (i.e., no support for different channels sampled at different rates).
*  No commented-event marker support.

*  No user annotation support.

Active X Controls
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ReadDatagFile ® ReadDatagFile Contral

Use ReadDatagFile to read WINDAQ-compatible files. In many instances, you may wish access to data acquired by
WINDAQ data acquisition software. Examples include custom analysis and export requirements. This control provides
a convenient way to perform these special operations.

Features of ReadDataqgFile include:
*  Open and close file manipulation capability.
»  File navigation utilities.
It also has the following limitations:
»  Supports only regular WINDAGQ files (i.e. no support for different channels sampled at different rates).
*  No commented-event marker support.

+  No user annotation support.

DataqSDK B DatagSdk Contral

DataqSdk provides access to the most basic elements of data acquisition hardware. Use DatagSDK with all DATAQ
Instruments’ hardware, including the DI-148U, DI-150, DI-151, DI-154RS, DI-158 Series, DI-190, DI-194RS, DI-
195B, DI-4xx products, DI-5xx products, DI-7xx products, DI-5001.

Features of DataqSDK include:
« Data acquisition mode definitions for continuous and triggered data acquisition.
«  Sample rate, channel, single-ended and differential definitions and various other scan list items.
» Immediate mode access to digital 1/0 and analog outputs.
e Access to acquired data using either burst or streaming methods.
e And more.
Limitations include:

» DataqSDK does not currently offer streaming DAC output.

(L0

DatagSerial (Obsolete) %" DatagSerial Contral

Note: The DatagSerial control is now obsolete and will no longer be supported. The DataqgSDK control should now
be used with serial devices. Some serial port devices may not work with DatagSerial.

Use DataqgSerial with all DATAQ Instruments’ hardware that supports a serial (COM port) interface, including the
DI-150/151/190/194/195 series devices. Use the DatagSDK control to access and manipulate all other DATAQ
Instruments’ hardware products like the DI-22x/4xx/5xx/7xx series devices.

DatagSerial features include:
»  Continuous access to acquire data.
»  Sample rate, COM port and acquired channel definitions.

» Access to acquired data using streaming methods.

Active X Controls
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DQChart

DQChart provides basic charting capabilities (as demonstrated in the Visual Basic samples included in the ActiveX
installation).

DQChart features include:
»  Plots up to 16 channels on the same chart.
»  Allows analog or digital plotting.
» Displays color legends at the upper left corner of the chart.
»  Supports scaling and offsetting via mouse control.
»  Supports WINDAQ compatible event marker.

*  Plots a specified channel from a data stream.

WinDaq  [*WinDag Caontral

Use the WinDaq control to eavesdrop on the data stream being acquired by WINDAQ Data Acquisition software. Use
this control to return a single value or the latest frame of data (using the data frame methods) or monitor the whole
data stream (using the data stream methods).

The primary advantage of this control is to relieve you of the tasks associated with initializing data acquisition. These
include, but are not limited to, scan list initialization and management, sample rate definitions, engineering unit scal-
ing and many others. These tasks are performed by WINDAQ turnkey data acquisition software at a very high level.
However, the data acquired by the application can be made available in real time by this control. In this manner, the
control allows you to concentrate on specific requirements of the task at hand without regard to mundane and obscure
data acquisition details.

WinDaq offers the following features:

»  Derives the number of channels, sample rate, engineering units scaling, m and b scaling constants and full-
scale ranges in engineering units as defined by Windaq software for each channel.

»  Provides access to acquired channel data using one of three options: immediate mode by defined channel,
immediate mode by all enabled channels and a stream approach that guarantees waveform continuity.

»  Allows asynchronous access to the hardware’s digital input and output ports and analog output ports.

Active X Controls
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6. XControls Software Option

DATAQ Instruments and locomp Software have collaborated to create XControls, a collection of software modules
that allow programmers and non-programmers alike to produce stunning graphical user interfaces (GUIs) for their
data acquisition applications. Designed specifically for DATAQ Instruments customers, the XControls work seam-
lessly with WINDAQ software. The “Linked Cell” property of each control provides exceptional power when coupled
with WINDAQ/XL software. WINDAQ/XL allows WINDAQ-acquired data to be ported to definable Excel cells both in
real time and after acquisition from the WINDAQ Waveform Browser (available on the DATAQ Instruments web site).
When those cells are linked to any given XControl using its LinkedCell property, the control has real-time access to
data: Thermometer columns rise and fall, panel meter displays update, angular display needles rotate to values, and
LED bar graphs change color and size. This is just one example of the many features included in the XControls.

Installing XControl Software

1. Insert the locomp CD-ROM into your CD-ROM drive. The installation should start automatically if you have the
AutoRun option turned ON. If it does not, open “My Computer” and then double-click on your CD-ROM drive.

2. Click on “Install locomp Components Version 2.0.”

3. Choose the folder where you want the files saved. Click Next.

4. When the “Welcome” window opens, click Next again.

5. Read the Terms of License Agreement. If you accept these terms, click Next.
6. Enter your user name and company name. Press Next.

7. Reconfirm the destination folder you selected in step 3. If correct, click Next. If incorrect, press “Browse” and
locate the correct folder.

8. Select “Typical Setup” to install all appropriate files required for your product and for the development environ-
ments automatically detected on your computer system.

9. Inthe Keycode Manager Window, enter your keycode in the “New Keycode” text box on the right. Your keycode
can be found on the label on the outside of the CD case. Please keep this number in a safe place as you will need
it for future installations and updates. Once you have entered your keycode, press the “Add Keycode” button
below the text box and then press Next.

10. In the next window, select the Development Environments that you wish to support. Auto-detected Development
Environments have already been selected. Add any others you wish to support and press Next.

11. Inthe OPC Options and Settings Window, choose whether or not you want to install support for OPC features.
Then press Next.

12. The Install Shield Wizard Complete Window will come up next. Choose if you would like to register your prod-
uct (Internet access is required) or display the Instrumentation Components Directory. Then click Finish.

Using XControls with WINDAQ/XL

This tutorial will show you how to use XControls in Excel with WINDAQ/XL. WINDAQ/XL is DATAQ's software
add-on to WINDAQ Software that allows data acquired by these packages to be ported to a Microsoft Excel spread-
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sheet. Let's say you need to measure the power and endurance of a motorcycle engine. You may want to test the
engine to see how long it can run at its maximum level without overheating. This would involve a control to measure
RPM, a control to measure the temperature, an odometer control, and an LED control that will let you know immedi-
ately when the engine has overheated. When you place all of these controls on a panel and label them, it might look
something like this:

Motorcycle Engine Test Stand
— 300
= g B g
— 225 3 L g
- &
= RPH .
=™ Overheated
= 2 A
— 7
- HEEH o 1 3
- 2 %1000
@0 i 10
Engine RPM
Temperature

Create and link controls in Excel in four simple steps:

Step One:
Go to View > Toolbars > Control Toolbox. This will display the Control Toolbox. Click on the “More Controls” but-

ton |2 in the lower right corner to reveal additional controls.

+ Control Toolbox ]

I

V Rl & EHER
FHIAR R

ignalogDisplay Control -

idnalogCukputy Conkrol

idngularzaugey Control

idngularLogGaugey Control

iCompassy Contral

iDual”ompassy Contral

itadienty Control

ikeyBoardy Control

iznobi Contraol

iLabel Control

iLedArrows Control
iLedEarx Control o

| 341 conkrals
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Step Two:

XControls have an “i” in front of them. When you find the one you want, click on it once. Your cursor will become a
cross hair. Click and drag to size the control or just click where you want it to be placed on the screen and it will

appear at its default size. In the example below, the iThermometer control was placed at its default size.

F3 Microzoft Excel - Book1
J File Edit “jew Insert Formakb Tools Data Window Help -|5’|5|
Dealee - > D22 25w
iKnobX1  =| -|—EMEIED( isAnalogLibrary. ikKnobX", ")
A 1 B [ ¢ [ b | E | F T & [ =
1 |“olt ol ol ol —
2 | 5737305 4.272461 1.953125 -11.8405
3 | 5737305 4.272461 1.953125 -11.8405 . = ".|ﬂ|,;;g
4 | 5737305 4.272461 1.953125 -11.8405
£ | 5737305 4.272461 1.953125 -11.8405
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Step Three:

When the control is placed, you will automatically enter “Design Mode.” Right click on the control and select “Prop-

erties” or just press the Properties button in the Control Toolbox. Here, you can change the properties of your
control, such as size, style, font, etc., but, most importantly, you can link the control to your application. Next to
“LinkedCell,” type in the Column and Row of the cell to which you would like the control linked. For example, to
specify a cell in Column “C,” Row 5, you would just type “C5.”
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E|
|iThermumeterx1 iThermometer =]
Alphabetic | Categorized
(AboLE) =
(Custom)
(Mame) iThermometersl
AukoCenter True
AukoLoad Falze
AukoScaleDesiredTicks 5
AukoScaleEnabled Falze
AukoScaleMax Ticks B
Awikoscalestyle 0 - iassAutokinia
BackGroundColor [ aHs000000F e,
BackGroundPicture (Bitrnap) o
BorderStyle 0 - ibsMone
CurrentMa 0
CurrentMin 0
Enabled True
Endstargin 10
Height 112.5
IndicatorBackaroundColor [ H000000E08:
[ndicatorBulbSize 6
[ndicatorColor B =HOOO00OFFS:
[ndicakorskyle 0 - itisBulb
[ndicatoritidth z
Left 23775
|
True
MaxPointerColar |:| 2HOOFFFFO02: ;I

You can change other properties by right clicking on the control and selecting “(the name of your control) Control
Object” and then click on “Properties” (for our example, you would select “iThermometerX Control Object” > “Prop-

erties”).
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This displays another window specific to the control (shown below for the “iThermometer” control).

iThermometerX1 Properties ﬂ

i Contral | About I

Cantrol I Design | AutoScale | OPC | Theme |

Position IEI [¥ Cached Drawing
Paosition b ax I'IEIEI [~ Transparent
Pasition Min ID

Current b ax IEI
Current kin IU

Ipdate Frame Rate IEEI jl [~ Auto Frame Bate

0Ok I Cancel Apply

Step Four:
To exit Design Mode and apply any property changes you have made to the control, click the “Exit Design Mode”

button &£ on the upper left-hand side of your Control Tool bar. This is also the button you need to press if you

want to enter Design Mode at any point to make changes to the control.

Your control is now linked!

XControls Documentation

The documentation for the XControls is on the CD as a pdf. To view the documentation, you must have Adobe Acro-
bat Reader. If you do not have Adobe Acrobat Reader, download it for free off the Internet at www.adobe.com. To
access the documentation, insert the CD. Close the Installation window. Double click on “My Computer” and then
right click on the CD-ROM drive. Choose the “Explore” option. This opens a window containing all of the folders on
the CD. Open the “DOC” folder and then, inside that folder, open the “General” folder. Inside this folder is the “Get-
ting Started Guide” pdf you need to use XControls.

The Getting Started Guide includes everything you need to operate XControls, except for the instructions for use with
WINDAQ/XL, which is included in this manual.

Chapter One covers which component architecture you should use. ActiveX, VCL and CLX component architectures
are included with your XControls. This chapter also gives an overview of XControls' key features and system require-
ments and tells you where you can locate help.

Chapter Two describes installation procedures, including custom setup, repair, service packs, and uninstall instruc-
tions as well as other procedures.

Chapter Three describes how to get started using the ActiveX component architecture. It covers setting up component
projects within Visual Basic and Microsoft Visual C++, including modifying control properties, generating even
code, basic programming usage and accessing help files. Chapter 3 also provides directions on distributing ActiveX
Component Files.
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Chapter Four covers how to get started using the VCL component architecture. It describes the process of compiling
and installing VCL components, accessing help files, distributing components, setting an environment library path,
modifying control properties, generating event code, and basic programming usage.

Chapter Five describes how to get started using the CLX component architecture. It covers setting up component
projects in Borland Delphi, C++ Builder, and Kylix, including compiling and installing CLX components, accessing
help files, distributing CLX components, modifying control properties, generating event code, and basic program-
ming usage.

Chapter Six details support options for XControls.
Appendix A contains a chart detailing each component library and what components they include.

Appendix B contains a table listing commonly used colors, their hexadecimal values and selected constants from
popular development environments.

Appendix C details the Transparency Feature, including how and when it can be used.

Appendix D details the Themes Feature, including how to use existing themes, how to create your own, how to use
themes in a compiled application using Run-Time Property Editors and more.

Appendix E contains the Software License Agreement.
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